Viking Forum banner
1 - 17 of 17 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
I have a 2021 Viking. I was riding last night and it just died. It will turn over but will not start. Anyone have any ideas on what it could be.
 

·
Registered
Joined
·
6,685 Posts
Without any more info I would guess out of gas.

Sent from my SAMSUNG-SM-G890A using Tapatalk
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
Full of gas and it’s getting spark. Not sure if it’s not get fuel yet
 

·
Registered
2020 Yamaha Viking EPS
Joined
·
715 Posts
Welcome to the forum. Like BadMonkey said, We will need more information please.
Did you try it again today?
Does it crank over?
Air filter clean?
Do you have spark?
Gas tank too full?
Any recent modifications?
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
It turns over fine got gas got spark. Just pulled fuel line and tried turning it over not getting any gas coming out
 

·
Registered
2020 Yamaha Viking EPS
Joined
·
715 Posts
Does fuel pump go through its priming sequence when turning key on? May have a blown fuse to fuel pump
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #8 ·
No it doesn’t. I found a 10 amp fuse that was blown and changed it. Still not getting anything to the fuel pump
 

·
Registered
2020 Yamaha Viking EPS
Joined
·
715 Posts
Did new fuse blow? Either way you have a short in that circuit. Do you have a service manual? It maybe the relay to the fuel pump, bad pump or a wiring problem. Find the fuel pump relay and try switching it with another one.
Is this still under warranty?
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #10 ·
Not under warranty anymore unfortunately. The fuse is still good. Getting a clicking noise from the starter relay.
 

·
Registered
2020 Yamaha Viking EPS
Joined
·
715 Posts
Did it die while driving it or when trying to start it? There are some threads posted here about solenoids going bad. Might try searching those. If memory serves me most are interchangeable so that may help troubleshooting.
 

·
Registered
2020 Yamaha Viking EPS
Joined
·
715 Posts
Any luck?
 

·
Registered
2018 camo VI
Joined
·
227 Posts
There are 3 relays on the passenger side under the hood. I believe the middle one is for the fuel pump. I replaced mine with a red top snowmobile solid stage one after mine would freeze up on me in sub zero temps and left me stranded miles from shore ice fishing. If your fuel pump isn’t turning on I’m guessing that could be the problem. Good place to check anyways. Good luck.
 

·
Registered
Joined
·
789 Posts
On the upper cross member, under the bed, on the passenger side, there is a white plug. It plugs the fuel injector into the wiring harness. Mine came apart once.
 

·
Registered
Joined
·
1,035 Posts
Try playing with the connector on the top of the starter relay. Cheers


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
6,685 Posts
Try playing with the connector on the top of the starter relay. Cheers


Sent from my iPhone using Tapatalk
Always playing with the connector Ironhide.

A Drunk Monkey
 
  • Like
Reactions: cactus
1 - 17 of 17 Posts
Top