Viking Forum banner

61 - 75 of 75 Posts

·
Premium Member
Joined
·
171 Posts
So I took my Viking down to dealership yesterday and told them that I thought the bearing holding the drive line may be the source of the noise they told me no it was fine and the sound was coming from the clutch area? I told them to hold off and I will contact jbs and hopefully that will eliminate it. I still think I am having same issue that you had!


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
5 Posts
I have 1050 miles on mine and we just started hearing a noise like this in the same place. I took the floor apart, and checked everything. Nothing was loose, but the way the front shaft is made its no wonder there could be a vibration. There are 2 u-joints, 2 carriers, and 3 shafts between the front diff and the trans. Not going to change anything yet, but I'm going to keep an eye on it. Thanks for the info Gunner73.
 
  • Like
Reactions: Gunner73

·
Registered
Joined
·
63 Posts
This is an old thread, but I finally took mine to the dealer almost 2 weeks ago for the same thing Ryan did. They had it over a week before even driving it, but I talked to them yesterday and they said, nope it's normal. Supposedly have one on the showroom floor that does the same thing. Not buying it though. It's about a 2 hour round trip that I don't want to make just to prove them wrong. Does anyone know if the seal in the parts diag here are the same as the pic Ryan Briggs posted? Any info would be appreciated. Thanks!
 

·
Super Moderator
Joined
·
4,182 Posts
Does anyone know if the seal in the parts diag here are the same as the pic Ryan Briggs posted? Any info would be appreciated. Thanks!

I don't think so, those two items that you coloured yellow are just rubber dust seals. Behind the left hand dust boot is a spacer, a bearing retainer, bearing, and a nut and yolk.
 
  • Like
Reactions: kynknwl

·
Registered
Joined
·
31 Posts
My Viking VI has a loud noise under the rear seat. At first I thought it was only when the vehicle was moving. But even when I rev the engine the noise is there. Sounds like a bad bearing or something.

Does the noise ya'll described only happen when the vehicle is moving or did it happen when the thing was in Neutral and you raved the motor?

I'm going to try and look into this more this weekend. Hopefully someone can give a quick post with some words of encouragement.
 

·
Super Moderator
Joined
·
4,182 Posts
I'm going to try and look into this more this weekend. Hopefully someone can give a quick post with some words of encouragement.

If you raise the bed does it sound like it's coming from inside the clutch/sheave area. That's really the only part of the drivetrain that is turning in neutral.
 

·
Registered
Joined
·
6,041 Posts
Besides saying where it is coming from and that it sounds like a bad bearing (rice krispies?? Squealing??) Have you done any work on the engine? When did it start? Is it super cold where you live? Does it go away and come back? Is it different in gear or moving? Does it speed up when you rev the motor?

Sent from the bottom of a whiskey bottle
 

·
Registered
Joined
·
31 Posts
OK guys, the short story is the guy that sold me the Viking VI rode her hard and put her away wet if ya know what I mean. Poor thing.

The noise was sort of hollow, and tinny. Almost like scraping too. You know how it is, mesh several sound together and you get a T-Rex sound that you know is really a combination of several critters. Exactly what it was is quite simple to explain. The 4 bolts holding the cage on the side of the clutch assembly, over the primary were stripped. The thing was just sitting in there, rattling like hell. Below you can see the burnt to hell bearing and the new one next to it.

50475



50498


The sad part is I didn't discover this to be the exact issue until I had already installed a new bearing and oil seal.
It's very important to have this cage on and secure. I'm an engineer by trade and took the time to draw up exactly what happens when you don't have the cage installed.

50477


Here's a few photos of what can happen when you let that Clutch Drum shaft sag...
50493

50480


Notice the wear on the one way bearing. Ouch...
50479


Photo of the oil after I drained it. If you look closely at the photos you can see little silver specks. Any guess as to what those are?

50492




3 oil changes later I was good to go! I ended up drilling out all 4 holes and threading in some Heli-coils in there. Bolt size was M6x1.00.

50497


50495



50496


I used red thread lock to fix them in place. These are far stronger than the aluminum they reside. It felt great to really torque those suckers down!
 

·
Registered
Joined
·
3,689 Posts
👏👏
Thanks for the pics, drawing and education.
 

·
Super Moderator
Joined
·
4,182 Posts
So how the heck does a cage come loose? I noticed a JBS sticker on it, so someone has put a JBS clutch kit/sheave in it and left the cage loose.
 
  • Like
Reactions: bd_skrillz

·
Registered
Joined
·
3,689 Posts
Obviously beer was involved
 
  • Like
Reactions: cactus

·
Registered
Joined
·
1 Posts
This is hard to explain but my Viking makes an odd noise mostly at low speed or going downhill from the drivetrain. It's not like metal on metal or grinding. I've had it to the dealer and was told its normal. Anyone else have a strange noise??


Sent from my iPhone using Tapatalk
What did you end up finding out
 

·
Super Moderator
Joined
·
4,182 Posts

·
Registered
Joined
·
113 Posts
I also noticed some rattling noise at deceleration and slow speeds. Under the floor boards. I took the middle floor panel off and started the machine. The slip joint on the rear of the drive shaft had some play in it. I had this issue with my ford excursion. To grease it the right way you need to pull the shaft out and pack it with grease. But to make it easier I drilled in a grease zerk and I think that is what I’m going to try later this afternoon. Try to eliminate the annoying rattle.
 

·
Registered
Joined
·
6 Posts
Ok so my noise was coming from the short driveshaft between the engine and rear-end. There is a plastic bushing in there that was busted and seal was leaking a bit. No more annoying noise.


Sent from Briggs iPhone using Tapatalk
Was the shaft loose as well or just making noise?
 
61 - 75 of 75 Posts
Top