Viking Forum banner

21 - 40 of 73 Posts

·
Registered
Joined
·
60 Posts
Ok so my noise was coming from the short driveshaft between the engine and rear-end. There is a plastic bushing in there that was busted and seal was leaking a bit. No more annoying noise.


Sent from Briggs iPhone using Tapatalk
Good to know! So did they get it fixed up pretty quickly?
 

·
Registered
Joined
·
148 Posts
I don't have one. The mechanic at our dealer is a friend of mine and he told me about it after he found it.


Sent from Briggs iPhone using Tapatalk
 

·
Premium Member
Joined
·
171 Posts
Ok so my noise was coming from the short driveshaft between the engine and rear-end. There is a plastic bushing in there that was busted and seal was leaking a bit. No more annoying noise.


Sent from Briggs iPhone using Tapatalk


Would you mind taking a picture of the spot you fixed( if not to much trouble) thanks.


Sent from my iPad using Tapatalk
 
  • Like
Reactions: Gunner73

·
Registered
Joined
·
148 Posts

My phone is being dumb I can't draw on the picture but it is the left side where the driveshaft goes into the engine.


Sent from Briggs iPhone using Tapatalk
 

·
Premium Member
Joined
·
171 Posts

My phone is being dumb I can't draw on the picture but it is the left side where the driveshaft goes into the engine.


Sent from Briggs iPhone using Tapatalk


Sweet thanks I will check mine out


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
139 Posts
Discussion Starter #29
I don't have a leak but the noise is loud and **** annoying. Taking it to the dealer today..


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
148 Posts
I found it lol. It's hard to hear on there but the end of your video sounded like the same clank as mine when u took off. But before it sounded like u-joint noise


Sent from Briggs iPhone using Tapatalk
 

·
Registered
Joined
·
9 Posts
Yay! Glad to hear you got it fixed, Ill keep that in mind. Mine is squeking cause it already needs brake pads IDK why i havent used it but 15 hours, but dealer says something may have got in it and is my responsibility.
Anyone else having brake pads fail less than 20 hours into use?
 

·
Registered
Joined
·
148 Posts
Yay! Glad to hear you got it fixed, Ill keep that in mind. Mine is squeking cause it already needs brake pads IDK why i havent used it but 15 hours, but dealer says something may have got in it and is my responsibility.

Anyone else having brake pads fail less than 20 hours into use?


All u need to do is take your breaks apart and use brake anti squeak lube on them and u can get rid of the squeak.


Sent from Briggs iPhone using Tapatalk
 

·
Super Moderator
Joined
·
4,115 Posts
Anyone else having brake pads fail less than 20 hours into use?
Yes, you'll find that your pads still have plenty of life left in them though, there just isn't enough adjustment at the lever end, so you'll have to go to the caliper for adjustment. Badmonkey wrote an excellent write-up on how to adjust the park brake caliper, you basically just back off the lock nut, turn the shaft in a bit, then do up the lock nut up. I'll see if I can find the write-up.
 
21 - 40 of 73 Posts
Top