Viking Forum banner
1 - 20 of 25 Posts

·
Registered
Joined
·
432 Posts
Discussion Starter · #1 ·
i think my transmission broke as i am getting a bad snapping sound and see oil leaking at tranny.it seems fine until under a load.
 

·
Registered
Joined
·
6,685 Posts
How about some details about what caused it and what you mean by transmission. Rear diff? Clutch housing? How 'bout some pictures?

Sent from my SM-F707U using Tapatalk
 

·
Registered
Joined
·
432 Posts
Discussion Starter · #3 ·
i had just left the house and went up a hill and when i let off the gas to go down the hill i heard a snap then nothing untill i accelerated to climb again.it sounds like your front diff when locked up and gets into a bind,with the back wheels off the ground i can rotate the tires by hand and no noise,but iff i put it in gear with engine runnnig and try to acellerate the snapping noise comes back.i noticed the oil leak this morning and looks like its coming from the bottom of the crankcase,hard to tell with belly pans welded on..
 

·
Registered
Joined
·
6,685 Posts
It is easy to pull the black plastic panel and fender liner on the drivers side. It will give a good view of that side.

Sent from my SM-F707U using Tapatalk
 

·
Registered
Joined
·
432 Posts
Discussion Starter · #6 ·
It is easy to pull the black plastic panel and fender liner on the drivers side. It will give a good view of that side.

Sent from my SM-F707U using Tapatalk
i have that removed,the only place i can see the leak is through the engine drain hole in skid plate.
 

·
Registered
Joined
·
432 Posts
Discussion Starter · #7 ·
Middle drive bolts probably came loose.
something is jammed in there ,i dont like the oil leak as the case must be cracked ..with the miles and hours on machine i'm not sure if i want to fix it or part it out.
 

·
Registered
Joined
·
6,685 Posts
something is jammed in there ,i dont like the oil leak as the case must be cracked ..with the miles and hours on machine i'm not sure if i want to fix it or part it out.
Good luck with it.

Sent from my SM-F707U using Tapatalk
 

·
Registered
2020 Yamaha Viking EPS
Joined
·
715 Posts
How old is it, and how many miles?
 

·
Super Moderator
Joined
·
4,580 Posts
I'm with buckg2, your middle gear has come loose and cracked the case, best not to drive it.
 

·
Registered
2020 Yamaha Viking EPS
Joined
·
715 Posts
Where is the middle gear located?
 

·
Registered
Joined
·
789 Posts
Under the airbox between the seats. You can unhook and slide the front drive shaft ahead. Take out 4 bolts and pull off the bearing carrier. Use a flashlight and look inside the case, you can see if the 4 bolts holding the middle drive gear to the case came loose.
 

·
Registered
2017 Viking EPS
Joined
·
66 Posts
Under the airbox between the seats. You can unhook and slide the front drive shaft ahead. Take out 4 bolts and pull off the bearing carrier. Use a flashlight and look inside the case, you can see if the 4 bolts holding the middle drive gear to the case came loose.
That's good info. Thanks for sharing. Probably a dumb question but is there a way to tighten them without splitting the case? I haven't looked into this.
 

·
Registered
Joined
·
789 Posts
No way to tighten them that I know of. Got to pull the motor.
 

·
Registered
Joined
·
432 Posts
Discussion Starter · #17 ·
i talked with dealer mechanic and after tearing engine apart he said the case looks good,the bearing housing for the pinion had snapped and wrecked the pinion gears.
 

·
Registered
Joined
·
6,685 Posts
Good luck!

Sent from my SM-F707U using Tapatalk
 

·
Registered
Joined
·
6,685 Posts
They should give you a loaner
 
1 - 20 of 25 Posts
Top