Viking Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
Been a board forum member for a bit here, but feel official today as I picked up my Viking from the dealer after what felt like a year wait. I bought a Blue Viking with hard top, winch and plow, no eps though. As soon as I figure out how to post pics I'll get one on here.
Trevor
 

·
Premium Member
Joined
·
3,378 Posts
Congrads and welcome aboard

Do you have some pics saved on your PC?

if so, when in a thread like this, below the quick reply box, click "Go Advanced" then click on Manage Attachments, then click choose file, and then upload, there ya go. Got any other quesitons, feel free to ask.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #4
Yeah I have a picture on my computer, but I keep getting an error when I try to attach it that way. I'll figure it out at some point. Thanks for the help.
 

·
Premium Member
Joined
·
3,378 Posts

·
Premium Member
Joined
·
3,378 Posts
Here ya go
 

Attachments

·
Premium Member
Joined
·
3,378 Posts
I really like that color, super nice.

Is that an Altima in the background?
 

·
Registered
Joined
·
16 Posts
Discussion Starter #8
Yeah I like the blue as well. And yes that is a 2011 Altima S in the back ground, its a pretty basic one, a nice ride though.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #10
Lol as much as I hate winter, I got tired of paying someone to plow my drive way. Now just hoping we get some, sometime soon.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #11
I'll get some more pics and possibly videos up over the winter, as my buddy has 40 acres that I can go ride on whenever I want. They go up there and tear around on their atvs/utvs and pull tubes behind, on the snow, lots of fun.
 
1 - 11 of 11 Posts
Top