Viking Forum banner
1 - 11 of 11 Posts

· Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I have a 2015 Viking 6 hunter edition that recently overheated and cracked head. I had the head replaced and new oil coolant ect but now the machine tops out at 30mph or so hitting rev limiter. Was running fine on top end before overheating issue. Got a code 42 which is speed sensor that I replaced and check engine and eps light went away and regained power steering but the thing just won’t go like it did. Any thoughts?
 

· Registered
2020 Yamaha Viking EPS
Joined
·
1,629 Posts
Welcome to the forum.
Did anything else get serviced at this time like the CVT primary? How long since CVT was last serviced because this could be your issue. Were the valves adjusted at the time you did the head replacement? Have you searched this forum for over heating issues and cracked or warped head? A lot here about these problems.
 

· Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Welcome to the forum.
Did anything else get serviced at this time like the CVT primary? How long since CVT was last serviced because this could be your issue. Were the valves adjusted at the time you did the head replacement? Have you searched this forum for over heating issues and cracked or warped head? A lot here about these problems.
I believe the guy only rebuilt the top en and nothing else. But it was going regular speed when it happened. After, 26 mph then limiter.
 

· Registered
2020 Yamaha Viking EPS
Joined
·
1,629 Posts
Then I would be asking the guy that did the work for a complete run down on everything he did. You may want to take it back to him and say make it right, didnt do this before.
 

· Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
Then I would be asking the guy that did the work for a complete run down on everything he did. You may want to take it back to him and say make it right, didnt do this before.
Engine runs flawless. It just that before when I would accelerate the the rpm’s wouldn’t get high unless I was going close to 50. Now it accelerates great but get in the limiter. It’s as if the thing isn’t like shifting up.
 

· Registered
2020 Yamaha Viking EPS
Joined
·
1,629 Posts
Really that sounds like CVT primary and secondary need servicing. When was the last time that was done? Maybe just a coincidence that it is happening at the same time as the head rebuild.
 

· Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
Really that sounds like CVT primary and secondary need servicing. When was the last time that was done? Maybe just a coincidence that it is happening at the same time as the head rebuild.
Umm never.. that looks horrible now that I typed it.. it’s very strange indeed cuz I was hauling the mail trying to get back to camp when it quit.. bud thank you for the help, guess I need to figure out how to service that..
 

· Super Moderator
Joined
·
5,195 Posts
Got to be something to do with the failed speed sensor, has it been reset?
 

· Registered
2020 Yamaha Viking EPS
Joined
·
1,629 Posts
How many miles are on your Viking?
 

· Registered
Joined
·
5 Posts
Discussion Starter · #10 ·
Got to be something to do with the failed speed sensor, has it been reset?
Sorry for delay. No if hasn’t been reset but since my last post I serviced primary and secondary. The machine gained about 5mph but now when I reach rev limiter going down hill it’ll free roll with no engine brake. When it hits 25 or so it re engages. Installed new oem belt also. I also made sure not to get grease on sheaves or belt.. I’m going back to ranch tomorrow to check for any other codes.. Maybe the computer does need resetting. Idk??
 

· Registered
2020 Yamaha Viking EPS
Joined
·
1,629 Posts
No engine breaking,... then something in secondary did not get replaced right. This could effect your top speed too. may want to put a new secondary spring in it when you take it apart again with the new slippery washers and Tinlseal grease. Did you check the condition of the wet clutch when you were in there?
 
1 - 11 of 11 Posts
Top