Viking Forum banner
1 - 19 of 19 Posts

·
Registered
Joined
·
84 Posts
Discussion Starter · #1 ·
How has everyone been mounting their light bars on the roof ? I don't want to drill holes in my roof , and I have a wind shield on also. Just looking for some ideas ?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
210 Posts
What makes you not want to drill into the roof of your Viking? Are you afraid you are going to make a mistake?

The only other thing I can think of is using a clamp of some ind to secure it to the roll cage.
 

·
Premium Member
Joined
·
1,369 Posts
How has everyone been mounting their light bars on the roof ? I don't want to drill holes in my roof , and I have a wind shield on also. Just looking for some ideas ?


Sent from my iPhone using Tapatalk

I have a 30" light bar and was going to build a bracket and mount in at dash level. However, I put it down there and when I lit it up, the glare off the hood was horrible. I mounted mine on the roof with no problems, and it's far enough back that, even though I now have a front windshield, I get very little glare. I have photos posted in the photo gallery.

The holes were really no big deal....and I used clamps on the roll cage, so it's solid.
 

·
Registered
Joined
·
291 Posts
I have a 14 inch light bar mounted on roof and as mass n trash stated not a big deal to mount using the roll bar clamps.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
84 Posts
Discussion Starter · #6 ·
I just don't want to start drilling holes in a utv that I just spent over 13 grand for . I will come up with something . Thanks for the help


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
84 Posts
Discussion Starter · #7 ·
Where is every one getting their lights from ?
 

·
Registered
Joined
·
57 Posts
Craigslisted mine for cheap. I feel you on the lights on the roof thing. These guys told me to buy the piaa mounts and they are solid. I still have it mounted under the roof but that might change after a windshield is purchased.
 

·
Registered
Joined
·
268 Posts
Amazon and ebay has a bunch of options.



20" 60 Watts CREE LED Light Bar ATV Tractor Trailer Rhino Kubota John Deere 12V | eBay

LED Power: 60W - 5400 Lumens
Operating Voltage: 10-30V DC
Waterproof rate: IP 67
12pcs*5w high intensity CREE LED
Current draw 4.8A @ 12V, [email protected] 24V
Color Temperature: 6000K
Material: Diecast aluminum housing
Lens material:Toughed glass
Mounting Bracket: Zince Alloy
Beam Pattern: Spot (8 Degree)
30000 hours above life time
Dimensions: 20 inch

for $139 its not bad at all
 

·
Registered
Joined
·
312 Posts
Here is where I put mine. ( 9" Alpha Series MaxLumens 4300 Lumens).




9" Alpha Lightbar
56 Watts, 4300 Lumens
Combo Beam
Operating Voltage: 10-30 DC
Color Tempature: 6000K
Waterproof Rate: IP 67
Diecast Aluminum Housing
 

·
Registered
Joined
·
84 Posts
Discussion Starter · #12 ·
I dont want to put mine on the bumper , snow blade blocks lights in the up position . Ebay is where my boss got his . What is the watts that the stator can handle?
 

·
Registered
Joined
·
312 Posts
I dont want to put mine on the bumper , snow blade blocks lights in the up position . Ebay is where my boss got his . What is the watts that the stator can handle?
I understand, we don't have a need here in Mississippi for to many snow plows. I went to a 30 amp switch and put a 25amp inline fuse from battery to the on/off(lighted) switch. I used 16 guage to run to the light and battery. I didn't tie into anything( high/low beams, helment & seatbelt).
Went straight to and from battery for ( + & -) feeds.
 

·
Registered
Joined
·
84 Posts
Discussion Starter · #15 ·
Well right now everything got put on hold . Having electrical issues right now . Took delivery of my brand new Viking Monday of this week , got it home and went for a short ride with my wife , son ,and i road around for about a half hour got back to house , shut it off let my wife and son get out went to start it back up battery was DEAD no big deal put it on trickle charger it , charged right up . Went out yesterday , half way threw the ride the engine light came on and low bat came across lcd screen !! Had to call brother in law to come and give me a jump . Needless to say its back at the dealership , dropped it off this morning , i know they will make it right . But already having problems is not good
 

·
Registered
Joined
·
84 Posts
Discussion Starter · #16 ·
We'll went and picked my Viking up , it was the stator in hooked from factory


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
3,378 Posts
Looks good Quak Addict
 

·
Registered
Joined
·
312 Posts
We'll went and picked my Viking up , it was the stator in hooked from factory


Sent from my iPhone using Tapatalk
Here's the answer to your previous stator question. I suggest you not leach off of an adjacent power source and isolate it to & from the battery......JMO
 
1 - 19 of 19 Posts
Top