Viking Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
372 Posts
You will be rockin before the weekend! Post some pics of your install when you have time....
 

·
Registered
Joined
·
1,187 Posts
Hey, From experience with installing my own custom stereo...... Do not wire directly to the battery and use the on/off on the stereo for turning it on, I did this about 2 months ago and was just turning the radio off and now my battery is cooked, (replacing it today).. I already cut the hot wire and installed a toggle switch.. It sucks it wont keep presets or time now but I don't want to be replacing batteries all the time
 

Attachments

·
Registered
Joined
·
142 Posts
Discussion Starter · #5 ·
I'm going to install a second battery under the drivers seat an run the stereo from it. An put a battery keyed disconnect switch in on my dash between the two battery's.



Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
21 Posts
I also use the toggle switch method, however I don't turn the toggle switch off until I'm completely done riding for the weekend. I never really notice a problem with the memory wire running down the batt unless it sits for a long time.
 

·
Registered
Joined
·
1,187 Posts
I also use the toggle switch method, however I don't turn the toggle switch off until I'm completely done riding for the weekend. I never really notice a problem with the memory wire running down the batt unless it sits for a long time.
..

Mine will usually sit all week and get used on the weekends.. . from about 2 months, it nuked the battery... had it tested and it tested 'bad cell' and wouldn't charge.. hopefully the toggle switch will solve the problem.. my new battery is a 450 ish crankin amps and like 350 cold crankin.. I got it at napa for 50 bucks... dealer wanted 130
 

·
Premium Member
Joined
·
631 Posts
..

Mine will usually sit all week and get used on the weekends.. . from about 2 months, it nuked the battery... had it tested and it tested 'bad cell' and wouldn't charge.. hopefully the toggle switch will solve the problem.. my new battery is a 450 ish crankin amps and like 350 cold crankin.. I got it at napa for 50 bucks... dealer wanted 130
Sounds more like a bad battery from the start, a bad cell is internal problems with it, not just being drained from something being left on

Sent from my SM-G900V using Tapatalk
 

·
Registered
Joined
·
142 Posts
Discussion Starter · #10 ·
I will post pics after I get done installing it should be done by Monday.


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
1,187 Posts
Good job bud!
 

·
Registered
Joined
·
2,011 Posts
looks awesome and sounds good. nice job!
 
1 - 16 of 16 Posts
Top