Viking Forum banner

1 - 20 of 33 Posts

·
Registered
2014 yamaha viking
Joined
·
24 Posts
Discussion Starter #1
Hi, I'm new to this forum. I just got a good deal on a 2014 viking. A friend of mine couldn't figure it out so I got it from him. It's starts but as soon as I press the throttle it dies. If I partially cover the snorkel with my hand it runs perfect. I think it's all stock besides the snorkel. He didn't tell me when the problem started or anything. I know he changed the fuel pump but not sure what else. I just replaced the coil. Any Ideas of what could be causing this? Thanks for any help.
 

·
Super Moderator
Joined
·
4,349 Posts
Probably the snorkel
 

·
Registered
2020 Yamaha Viking EPS
Joined
·
333 Posts
Is the air intake (snorkel) stock or modified? Is the air filter clean and stock or modified?
 

·
Registered
2020 Yamaha Viking EPS
Joined
·
333 Posts
I would also try to get as much information from your friend as possible to what he has done and what led up to this, for a better understanding of the problem.
 

·
Registered
2014 yamaha viking
Joined
·
24 Posts
Discussion Starter #5
Homemade snorkel 2". It goes from the air box to just even with the head rest. The air filter was falling apart so I replaced it with a uni air filter. I know he replaced the fuel pump and I think ecu. It seemed to run better when the tps was adjusted a little high. When I first got it I cleaned the spark plug and it ran perfect for about 5 minutes then started sputtering out again. So I changed the plug and coil. That didn't help.
 

·
Registered
2020 Yamaha Viking EPS
Joined
·
333 Posts
Do you need the snorkel? Sounds like you need get rid of it and put it back to stock
 

·
Registered
2014 yamaha viking
Joined
·
24 Posts
Discussion Starter #7
I like to keep the snorkel. I can take it off and see if that helps. I'll ask my friend tomorrow and see when the problem started and try to get some details from him. He seemed to think the problem was electrical like a sensor or something.
 

·
Registered
2014 yamaha viking
Joined
·
24 Posts
Discussion Starter #8
Could the stator cause any of this? I just had to jump it off and with jumper cables hooked up it ran much better. I have a car battery in it at the moment because the other was bad.
 

·
Super Moderator
Joined
·
4,349 Posts
Does it run ok with the car battery? Take the air filter out and see how it runs, then take the snorkel off and try it. It could be the injector dumping too much fuel I think.
 

·
Registered
2014 yamaha viking
Joined
·
24 Posts
Discussion Starter #10
I've been messing with it tonight and I couldn't get it to start and idle until I hooked the jumper cables from my truck to it then I could get it to start and idle. I hooked jumper cables up because the car battery died from trying to start it. When I give it gas it wants to die. I have to get it idling and cover the snorkel with my hand until it barely gets any air to be able to gas on it. I have to starve it of air so much the air tube thing going from the air box to the motor starts collapsing but it will run great as long as I keep my hand on it. I really appreciate everyone's help. This thing is driving me nuts trying to figure it out. It seems like not enough gas or to much air. The injector is working but I haven't checked the pressure yet. I'm not sure if the air induction could cause this or not. I'm thinking I need to check pressure from the injector.
 

·
Registered
Joined
·
6,127 Posts
I am not going to pretend I know what is going on but I think mine runs fine with the top off of the air filter housing. Can't imagine why it needs to be choked.

Sent from my SM-F707U using Tapatalk
 

·
Super Moderator
Joined
·
4,349 Posts
I've been messing with it tonight and I couldn't get it to start and idle until I hooked the jumper cables from my truck to it then I could get it to start and idle. I hooked jumper cables up because the car battery died from trying to start it. When I give it gas it wants to die. I have to get it idling and cover the snorkel with my hand until it barely gets any air to be able to gas on it. I have to starve it of air so much the air tube thing going from the air box to the motor starts collapsing but it will run great as long as I keep my hand on it. I really appreciate everyone's help. This thing is driving me nuts trying to figure it out. It seems like not enough gas or to much air. The injector is working but I haven't checked the pressure yet. I'm not sure if the air induction could cause this or not. I'm thinking I need to check pressure from the injector.
So that's telling you that it's not getting enough fuel. How do you know that the injector is working?
 

·
Registered
Joined
·
745 Posts
I believe there is an air sensor in the air box. Make sure it got plugged back in. It's under the air box, lower back left corner.
 

·
Registered
Joined
·
380 Posts
when you took the plug out was it wet or dry?this will tell you if your getting too much or not enough fuel,might be the plug itself
 

·
Registered
2014 yamaha viking
Joined
·
24 Posts
Discussion Starter #15
16090996082253028089335055622920.jpg
I just bought this plug and put it in. I started it and took a short ride. I was running but sputtering bad and after a few minutes would die without choking the snorkel. I pulled the injector off to see if fuel was coming out of it the other day. But I didn't check it beyond that.
 

·
Registered
Joined
·
3,796 Posts
What a PITA.

You'll get it fixed.

These jokers are very helpful.
 

·
Registered
Joined
·
3,796 Posts
Encouragement is all I'm good for. That and cheering. I'm in your corner!
 

·
Registered
2014 yamaha viking
Joined
·
24 Posts
Discussion Starter #19
Encouragement is all I'm good for. That and cheering. I'm in your corner!
Lol anything helps. This thing is not making it easy for me. I'll think I almost have it figured out then the problem is still there. I haven't worked on fuel injected bikes before so I'm learning as I go. Thanks for any help I can get.
 

·
Registered
2020 Yamaha Viking EPS
Joined
·
333 Posts
Have you considered bad fuel?
 
1 - 20 of 33 Posts
Top