Viking Forum banner
1 - 17 of 17 Posts

·
Registered
2019 Viking 700 Ranch Edition EPS
Joined
·
5 Posts
Discussion Starter · #1 ·
Engine was rebuilt in February after sinking in mud. Ridden very little since in comparison to prior. Seemed fine last Saturday at deer lease, but on Sunday, after driving about a mile its started surging/cutting out at and wouldn't go over 12mph. Any help is greatly appreciated!
 

·
Super Moderator
Joined
·
5,053 Posts
Is it hitting the rev limiter do you think?
 

·
Registered
2020 Yamaha Viking EPS
Joined
·
1,368 Posts
Start with a new spark plug. It maybe fouled. Is gas good, no water in it?
 

·
Registered
2019 Viking 700 Ranch Edition EPS
Joined
·
5 Posts
Discussion Starter · #5 ·
Is it hitting the rev limiter do you think?
Start with a new spark plug. It maybe fouled. Is gas good, no water in it?
Ok. I'll check it, but it should be basically new, and it's not missing. Gas came straight from pump day before. It does feels like it's running out of gas, which is almost full, but only does it at12 mph in hi and low gears only. Reverse, it works fine. Guess I'll just have to start riding it backwards. Haha
 

·
Registered
Joined
·
7,300 Posts
Sounds like a problem with a sensor that is triggering the rev limiter by accident. Maybe a wire or connection is loose or pinched / shorted.
 

·
Registered
2020 Yamaha Viking EPS
Joined
·
1,368 Posts
Can you get to go over 12mph? It does sound like rev limiter is kicking in. Is it in Diff-lock?
 

·
Registered
Joined
·
7,300 Posts
The difflock cut out is at 3 mph
 

·
Registered
2020 Yamaha Viking EPS
Joined
·
1,368 Posts

·
Registered
Joined
·
7,300 Posts
I mean at 3 it will stumble if not 100% engaged
 

·
Registered
2019 Viking 700 Ranch Edition EPS
Joined
·
5 Posts
Discussion Starter · #12 ·
Sounds like a problem with a sensor that is triggering the rev limiter by accident. Maybe a wire or connection is loose or pinched / shorted.
Ok. I have a service manual, but it's a pain in the butt to read. I will definitely look into this. Also, went to check the spark plug/ignition system for s & g's and the wire very easily pulled out of the spark plug boot. Is that the way they're made? It's very odd if so. However, it's not misfiring, so I don't think it's ignition related.
 

·
Registered
2020 Yamaha Viking EPS
Joined
·
1,368 Posts
Yes that’s normal for the plug wire and boot, at least I think so because mine did the same thing and I panicked, but after shoving it back in it has been fine with no issues.
 

·
Registered
Joined
·
3 Posts
Engine was rebuilt in February after sinking in mud. Ridden very little since in comparison to prior. Seemed fine last Saturday at deer lease, but on Sunday, after driving about a mile its started surging/cutting out at and wouldn't go over 12mph. Any help is greatly appreciated!
My 2018 did that and it was because my seat belt was not fastened.
 

·
Registered
2020 Yamaha Viking EPS
Joined
·
1,368 Posts
Dhorn, any resolution to this problem yet?
 
  • Like
Reactions: cactus

·
Registered
2020 Yamaha Viking EPS
Joined
·
1,368 Posts
The OP never came back here since his last post. Check my response in your original post on this.
 
1 - 17 of 17 Posts
Top