Viking Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Having issues with a 2016 Viking cutting out at 38 mph and won’t go any faster. Went in some deep water last weekend. Belt slipped. Got pulled out. Left it idle while drained cvt case. 15 min later no issues. Ran fine but probably didn’t get it up to 38 mph at that time. Let it dry out for a few days and noticed this problem. It always happens right at 38. If I push harder it still runs but cuts out. Changed oil. New spark plug. Cleaned and oiled air filter and same issue. What could it be causing this?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
Having issues with a 2016 Viking cutting out at 38 mph and won’t go any faster. Went in some deep water last weekend. Belt slipped. Got pulled out. Left it idle while drained cvt case. 15 min later no issues. Ran fine but probably didn’t get it up to 38 mph at that time. Let it dry out for a few days and noticed this problem. It always happens right at 38. If I push harder it still runs but cuts out. Changed oil. New spark plug. Cleaned and oiled air filter and same issue. What could it be causing this?
Checked it in low and it seemed to cut out around 28. Is there a rev limiter that would tell it to cut out at that speed? Also with the dif lock on, it cuts out almost automatically. I’ve not used the dif lock much so I can’t say it is a problem.
 

·
Super Moderator
Joined
·
4,182 Posts
The engine has a rev limiter for top speed, when you hit it it starts missing. 28 is probably right for low but high should be higher than 38. There's also a rev limiter on the diff lock, it'll cut out while diff lock is engaging which can take a while. Once the red light stops flashing it should run normal.
 

·
Registered
Joined
·
68 Posts
I would take your CVT cover off and clean it out and repack the primary with new grease since it all got wet and the water may have brought in dirt with it.
 

·
Registered
Joined
·
22 Posts
Is your driver side seatbelt engaged? Not sure if they had one of those safety switches on that model...
 

·
Registered
Joined
·
68 Posts
Having issues with a 2016 Viking cutting out at 38 mph and won’t go any faster. Went in some deep water last weekend. Belt slipped. Got pulled out. Left it idle while drained cvt case. 15 min later no issues. Ran fine but probably didn’t get it up to 38 mph at that time. Let it dry out for a few days and noticed this problem. It always happens right at 38. If I push harder it still runs but cuts out. Changed oil. New spark plug. Cleaned and oiled air filter and same issue. What could it be causing this?
ever get this figured out?
 

·
Registered
Joined
·
155 Posts
Clean and replace grease in the clutch. make sure you don’t use too much grease and use ultramatic Yamaha grease
 
1 - 7 of 7 Posts
Top