2019 Viking SE - Yamaha Viking Forum
 2Likes
  • 1 Post By Kbhowe1
  • 1 Post By cactus
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 04-07-2019, 01:19 AM Thread Starter
Junior Member
 
Join Date: Apr 2019
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
2019 Viking SE

Hello all,

New to the forum here and just a quick question. I recently purchased a new 2019 Viking SE edition. My question is are the springs or shocks any different than the base model? My SE are red in color but are they any different than the others? I an putting on a warn VRX 45 and the warn 72” plow so just want to see if I will eventually have to upgrade or not. Thanks in advance, love the Viking so far, except the brake squeaking what’s up with that?
bd_skrillz likes this.
Kbhowe1 is offline  
post #2 of 4 (permalink) Old 04-07-2019, 07:31 AM
Super Moderator
 
Join Date: Apr 2014
Location: NSW, Australia
Posts: 3,828
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1263 Post(s)
Hi and welcome to the forum, as far as I know your springs/shocks are exactly the same as the other Viking III models. I think that the only model that has different springs is the Viking VI, which has heavier springs on the rear. The spring rates are put up here somewhere for each of the models. Brake squeak has been an issue on some Vikings, if you search BadMonkey's brake squeak fix you will find a thread on how to grease it all up to end the squeak, I'll see if I can find the thread. Yeah and "what's up with that" exactly, brake squeak has been going on since 2014, Yamaha should have fixed it by now!!! Hope that helps!
bd_skrillz likes this.

Sent from the bottom of ANOTHER empty whiskey bottle.

Current Ride;
Chookbanger Mark II,
Street legal Blue Viking, 2017 model, bought 3/4/2017.

Previous Ride;
Chookbanger;
Street legal Blue Viking, 2014 model bought 3/4/2014, sold 3/4/2017 with 2850 km and 189 Hrs.
Yamaha Saggy Bottom Club member.

Other Yamaha Bikes Currently Owned
2019 WR250
2016 WR450
2016 YZ85 (sold)
2017 Grizzly 350 4x2 Auto Quad
2017 AG200
2005 PW50

Honda 2012 CB250
Honda 1999 CT200
Honda 1985 CT200 Trike

Last edited by cactus; 04-07-2019 at 07:40 AM.
cactus is online now  
post #3 of 4 (permalink) Old 04-07-2019, 06:09 PM Thread Starter
Junior Member
 
Join Date: Apr 2019
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Ok thanks for the quick reply. I think I did find the brake fix when I was looking around in the past. I think I also read that on some if went away on its own. I will most likely wait till the 1st service and if it’s still as annoying I’ll fix it then.
Kbhowe1 is offline  
 
post #4 of 4 (permalink) Old 04-10-2019, 12:03 AM
Senior Member
 
wildbill55's Avatar
 
Join Date: Jul 2016
Location: NorthCarolina
Posts: 338
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 83 Post(s)
Mine never stopped till I did the BadMonkey fix and they were actually grabbing on mine not releasing all the way,could tell a big difference after I finished..

2014 Red Viking
Venom 3500 winch
814 Susp.shocks
STI HD4 wheels,Tusk Trilobite tires 14x9x27
Yamaha OEM Floor Mats,Bed Mat,Roof, Windshield.Sound Proofing Kit.
Wolverine seats.Boafeng 2way
Works stereo,custom gauges
Heat sheild,Engine Stabilizer, Skid Plates
Herculined Bed,JBS sheave,weights,slugged clutch
18 inch front light bar,12 inch rear.4"cubes
Front and Rear Richocet A Arm guards
Bad Dawg side mirrors,OEM rearview mirror
Fan Override switch.Fender flares,Assault Steering
wildbill55 is offline  
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome