Won't Start, Fuel Pump Not Engaging - Yamaha Viking Forum
 1Likes
  • 1 Post By cactus
 
LinkBack Thread Tools
post #1 of 8 (permalink) Old 09-02-2019, 08:09 AM Thread Starter
Junior Member
 
Join Date: Jul 2019
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
(Thread Starter)
Won't Start, Fuel Pump Not Engaging

I took my Viking through some deep water last week and got some water in the airbox. I had some signs of water in my oil, not close to milkshake but you could see it. I changed the oil/filter four times.

I went to start it yesterday and when I turn the key to run I don't hear the fuel pump priming. When I try and turn it will crank but not fire the engine. When turning the key to start I am seeing the check engine light appear (not flashing) and it disappears when I stop trying to crank the engine.

Is there a diagnostic mode that I can access that will give me a code? I would really appreciate any troubleshooting tips as well.
Timbo is offline  
post #2 of 8 (permalink) Old 09-03-2019, 06:16 AM
Senior Member
 
BadM0nkey's Avatar
 
Join Date: Mar 2014
Location: Northwestern New Jersey
Posts: 5,903
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 1770 Post(s)
You can see some codes but you will need to look in the service manual.

Sent from the bottom of a whiskey bottle


2014 Green EPS Viking

Superwinch 4500
Denali Pro Plow
27" Interforce F & 28" Zillas R
ITP Delta 5+2 Wheels
Spring Spacers
UTV HQ Vent Windshield & Encl
EMP Wiper & Rear Bumper
Summit Racing Heater
YXZ SE Seats
JBS Guards,Skids & Sheave
4-Point Harnesses
Ultra Halogen Headlights
24" Light Bar
Power Sub-Panel
LED
XTREME Whip
Backup Camera & CREE Lights
Accent LEDs
Sound Dampening Kit
Center Console
Seizmik Mirrors
Extinguisher
TSC Bed Mat
Spare Carrier
BadM0nkey is online now  
post #3 of 8 (permalink) Old 09-03-2019, 07:31 PM Thread Starter
Junior Member
 
Join Date: Jul 2019
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
(Thread Starter)
Quote:
Originally Posted by BadM0nkey View Post
You can see some codes but you will need to look in the service manual.

Sent from the bottom of a whiskey bottle
Thanks for the info, I don't see any codes showing up on the screen. If the Viking is throwing codes will it show up automatically or do I have to enter a diagnostic mode to get the codes?
Timbo is offline  
 
post #4 of 8 (permalink) Old 09-03-2019, 10:32 PM
Super Moderator
 
Join Date: Apr 2014
Location: NSW, Australia
Posts: 3,828
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1263 Post(s)
You need the Yamaha tool to properly check all the codes, and I don't there is a code for the fuel pump anyway?? If you can't hear the pump running then check the relays and fuses, then check for 12 volts at the pump, or failing that pull the fuel hose off at the engine and see if fuel flows with the key on and/or engine cranking. Start from there and let us know how you go.

Sent from the bottom of ANOTHER empty whiskey bottle.

Current Ride;
Chookbanger Mark II,
Street legal Blue Viking, 2017 model, bought 3/4/2017.

Previous Ride;
Chookbanger;
Street legal Blue Viking, 2014 model bought 3/4/2014, sold 3/4/2017 with 2850 km and 189 Hrs.
Yamaha Saggy Bottom Club member.

Other Yamaha Bikes Currently Owned
2019 WR250
2016 WR450
2016 YZ85 (sold)
2017 Grizzly 350 4x2 Auto Quad
2017 AG200
2005 PW50

Honda 2012 CB250
Honda 1999 CT200
Honda 1985 CT200 Trike
cactus is online now  
post #5 of 8 (permalink) Old 09-04-2019, 04:16 PM Thread Starter
Junior Member
 
Join Date: Jul 2019
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
(Thread Starter)
Quote:
Originally Posted by cactus View Post
You need the Yamaha tool to properly check all the codes, and I don't there is a code for the fuel pump anyway?? If you can't hear the pump running then check the relays and fuses, then check for 12 volts at the pump, or failing that pull the fuel hose off at the engine and see if fuel flows with the key on and/or engine cranking. Start from there and let us know how you go.

Thanks for the help guys. I traced it back to a bad fuel injection relay. She is now up and running! I appreciate the patience with helping me track down this problem.
Timbo is offline  
post #6 of 8 (permalink) Old 09-04-2019, 06:40 PM
Senior Member
 
bd_skrillz's Avatar
 
Join Date: Jan 2015
Posts: 3,570
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1352 Post(s)
Quote:
Originally Posted by Timbo View Post
Thanks for the help guys. I traced it back to a bad fuel injection relay. She is now up and running! I appreciate the patience with helping me track down this problem.
No problem. Just let me know if you have more problems and I'll have Cactus or BM point you in the right direction. Of course, Cactus is going Honda soon so bleed his brain dry while he's still here - because I don't know a dang thing about mechanical things. ...and BM is usually drinking alone and running on ethanol.

2014 EPS Blooo Banger!
3500 LBS Warn Winch-72" Plow-JBS Extreme Sheave-16g Slugs
29.5 Terminators-MSA Wheels-2" Super ATV Lift-JBS Skids
Vented Windshield-Yam Roof-Surlast Rear Windshield-Seizmik Mirrors
Extinguisher-Engine Stabilizer-Sound Damp Kit-Fat Mat
Groundhog Plow-Koplin Grips-Opt7 Lights 32", 8"
Pyle Cam-7" Monitor-Ram Mount X-Grip
Concours Bus-Mictuning Switches-USB Chargers-Voltmeter-LED Whips
Mad Dog Console-Yam Bed Mat-Baofeng 2Way-Garmin GPS-Smitty Built Receiver
Etc. ka-ching!

Last edited by bd_skrillz; 09-04-2019 at 06:45 PM.
bd_skrillz is offline  
post #7 of 8 (permalink) Old 09-05-2019, 04:48 AM
Super Moderator
 
Join Date: Apr 2014
Location: NSW, Australia
Posts: 3,828
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1263 Post(s)
Quote:
Originally Posted by bd_skrillz View Post
No problem. Just let me know if you have more problems and I'll have Cactus or BM point you in the right direction. Of course, Cactus is going Honda soon so bleed his brain dry while he's still here - because I don't know a dang thing about mechanical things. ...and BM is usually drinking alone and running on ethanol.

First part false second part true!


.
bd_skrillz likes this.

Sent from the bottom of ANOTHER empty whiskey bottle.

Current Ride;
Chookbanger Mark II,
Street legal Blue Viking, 2017 model, bought 3/4/2017.

Previous Ride;
Chookbanger;
Street legal Blue Viking, 2014 model bought 3/4/2014, sold 3/4/2017 with 2850 km and 189 Hrs.
Yamaha Saggy Bottom Club member.

Other Yamaha Bikes Currently Owned
2019 WR250
2016 WR450
2016 YZ85 (sold)
2017 Grizzly 350 4x2 Auto Quad
2017 AG200
2005 PW50

Honda 2012 CB250
Honda 1999 CT200
Honda 1985 CT200 Trike
cactus is online now  
post #8 of 8 (permalink) Old 09-05-2019, 04:48 AM
Super Moderator
 
Join Date: Apr 2014
Location: NSW, Australia
Posts: 3,828
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1263 Post(s)
Quote:
Originally Posted by Timbo View Post
Thanks for the help guys. I traced it back to a bad fuel injection relay. She is now up and running! I appreciate the patience with helping me track down this problem.



Good to see you got it sorted!


.

Sent from the bottom of ANOTHER empty whiskey bottle.

Current Ride;
Chookbanger Mark II,
Street legal Blue Viking, 2017 model, bought 3/4/2017.

Previous Ride;
Chookbanger;
Street legal Blue Viking, 2014 model bought 3/4/2014, sold 3/4/2017 with 2850 km and 189 Hrs.
Yamaha Saggy Bottom Club member.

Other Yamaha Bikes Currently Owned
2019 WR250
2016 WR450
2016 YZ85 (sold)
2017 Grizzly 350 4x2 Auto Quad
2017 AG200
2005 PW50

Honda 2012 CB250
Honda 1999 CT200
Honda 1985 CT200 Trike
cactus is online now  
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome